Crypto currency

Bug in Ethereum client leads to split — EVM-compatible chains at risk

A major consensus bug has affected more than half the Ethereum network’s nodes, causing those running older versions of Geth to split from the main network.

According to Ethereum software developer Marius van der Wijden, an attacker exploited a vulnerability affecting earlier versions of Geth, one of Ethereum’s software clients. According to the developer, Geth clients and Ethereum nodes running software v1.10.7 or earlier are at risk of splitting from the network.

“Infura and the big exchanges seem to be on the good side of the fork, so all transactions through metamask should be golden,” said van der Wijden. “Users that run validators need to update their nodes quickly (in the next 10h I think) as they would otherwise vote on invalid committees.”

Related: Ethereum London hard fork goes live

Binance Smart Chain’s Twitter account and others had previously warned Geth clients to update to v1.10.8, which claimed to have a hotfix for the vulnerability in the earlier versions. Ethereum Virtual Machine- or EVM-compatible chains may also be at risk.

“Stay away from doing [transactions] for a while till confirmed, unless you are sure you are submitting to latest Geth,” advised Yearn.finance founder Andre Cronje.

This story is developing and will be updated.